Benutzername und/oder Kennwort falsch!

  • Hallo zusammen,

    ich hoffe, jemand kann schnell weiterhelfen.

    Und zwar war in der DB die tblError kaputt bzw. musste repariert werden. Jedoch komme ich jetzt nicht mehr ins Backend: Benutzername und/oder Kennwort falsch!

    Die Daten stimmen, auch wenn ich über die DB einen neuen User anlege.

    Hat jemand eine Idee? Ein Backup habe ich leider nicht :(

  • Hallo,

    Das klingt nicht so gut. Eigentlich sollte es nicht viel ausmachen, wenn die Tabelle tblError defekt ist und repariert wurde. Dort werden ja nur Fehler dokumentiert. Auf das Login sollte sich das meiner Einschätzung nach nicht auswirken.

    Ein paar Fragen:

    • Kann es sein, dass das Dateisystem bzw. die Datenbank voll ist?
    • Welche wE Version läuft denn da? Auch die MySQL und PHP Version sind relevant.
    • Gab es beim Hoster oder am System irgendwelche Änderungen? Der Fehler muss ja eine Ursache haben.
    • Sind die anderen Datenbanktabellen in Ordnung?
    • Kannst du über die Passwort Vergessen Funktion von webEdition ein neues Passwort setzen?

    Bzgl. Backup:

    Die meisten Hoster machen standardmäßig Backups für die letzten paar Tage. Hier kannst du ggf. mal anfragen. Restore kostet meist ein paar Euro, erlaubt dann aber zumindest von einem funktionierenden Startpunkt neu zu starten.


    Liebe Grüße,

    Sascha

  • Hallo,

    vielen Dank für die Rückmeldung.

    Leider ist das letztmögliche Backup schon nicht mehr funktionsfähig :(

    Da sieht man mal, wie wichtig es ist, Wartungsverträge und regelmäßige Backups zu machen.

    Zu deinen Fragen:

    • Kann es sein, dass das Dateisystem bzw. die Datenbank voll ist?
      => beides nicht voll, noch genug Platz
    • Welche wE Version läuft denn da? Auch die MySQL und PHP Version sind relevant.
      =>9.0.8.1 Barrhorn Nightly, MSQL 5.7 und PHp 7.3
    • Gab es beim Hoster oder am System irgendwelche Änderungen? Der Fehler muss ja eine Ursache haben.
      => angeblich nicht
    • Sind die anderen Datenbanktabellen in Ordnung?
      => ja, habe alle Tabellen repariert
    • Kannst du über die Passwort Vergessen Funktion von webEdition ein neues Passwort setzen?
      => funktioniert nicht. Da kommt: Das Formular wurde schon an den Server übermittelt. Eine erneute Übermittlung ist nicht möglich.

    Es scheint irgendwas mit der tblSession nicht zu stimmen. Wenn ich mich versuche anzumelden, macht es genau diese 5 Einträge anstatt einen korrekten Eintrag.

    Ich bin echt verzweifelt.

    Edited once, last by steff11 (September 25, 2023 at 3:40 PM).

  • Hallo Steff11, vermutlich tut das nix zur Sache, aber es gibt so was manchmal bei TYPO3 bei bestimmten Updatekonstellationen, dass das Sessioncookie im Browser den Loginvorgang stört. Meist hilft es die Cookies zu löschen oder einen andern Browser zu nehmen. Aber das hast Du vermutlich schon versucht.

    Viele Grüße

    ludger müller
    gestaltung für bildschirm und papier aus münster in westfalen

    https://artbeit.de

  • Hallo Steff11,

    ich tippe auf eines meiner Lieblingsprobleme beim Login, dass hier bereits einige hatten. Geh mal in die we_conf_global.inc.php und stell in der folgenden Zeile die Session-Verschlüsselung aus, in dem du folgendes setzt:

    Code

    Code
    //crypt we session before save
    define('SYSTEM_WE_SESSION_CRYPT', 0);

    0 = keine Verschlüsselung

    1 = Transparent

    2 = Cookie

    Wenn danach der Login wieder geht, hängt es damit zusammen.

    Gab es einen Server-Wechsel oder ein we-Update?

    VG Adrian

  • Wurde eventuell auf den neuen SSL Standard umgestellt? Falls ja, könnte der Fehler auch damit zusammen hängen. Dann würde ein Update auf 9.2.x helfen.

    --> Update müsste, wenn das die Ursache ist, auf einem anderen Server durchgeführt werden. Dafür einmal die Seite manuell kopieren, also Dateien und DB und in der Config entsprechend die neue DB eintragen.

  • Stimmt Finn, hatten wir auch mal bei ner Neu-Installation bei nem neuen Provider der OpenSSL 3.x einsetzt. Wenn man die Session-Verschlüsselung über die Config aus macht, konnte man jedoch wieder auf's Backend zugreifen und dann dort webEdition auf eine Version 9.1.5 oder höher updaten.

  • Vielen dank für eure Hilfe :)

    Browsercache etc hatte ich gelöscht und auch schon die Session-Verschlüsselung auf 0 gesetzt. Hilft beides nicht.

    Ich versuche mal die Seite auf einen anderen Server zu kopieren.

  • Leider hat dies auch nicht funktioniert :(

    Ich habe nun ein ganz altes Backup genommen und manuell bzw. mittels DB versucht, den letzten Zustand wiederherzustellen.

    Habe die kaputte Seite mal archiviert. Falls jemand noch eine Idee hat, es würde mich echt interessieren, wie man dies beheben kann.

  • Das Kopieren hat geklappt. Aber man kann sich auch auf dem neuen Server nicht einloggen bzw. das Problem besteht dort auch.

    Daher habe ich nun eine andere Lösung genommen, indem ich ein altes Backup aufgefrischt habe, weil es eilte.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!